How to Set up Net10 Wireless Data and MMS on Your Nokia Lumia Running Windows Phone 8

Introduction

I wrote this guide to share with you how I set up my Net10 Wireless data/internet connection and MMS picture messaging on my Nokia Lumia 920 running Windows Phone 8. While this guide shows how I set up my Nokia Lumia 920, I would expect it would work with other Nokia Lumia models or Windows Phone 8 smartphones.

For this guide, I expect you have an active Net10 Wireless SIM inserted into your phone. Your voice calls and SMS text messages show work already work. Your cellular data and MMS picture messaging will not work until you configure your phone.

I created this guide using a Nokia Lumia 920 and a Net10 AT&T compatible SIM. I was using one of the new Net10 SIMs so my phone gets 4G LTE service.

Click Continue to Page 2 to begin reading the guide. If you have a problem or question leave a comment and I will try to help you.


50 Comments

  1. Rhonda | | Reply

    Hello,I tried all the different apn settings that were listed and I still can’t send or receive picture msgs.my data connection works without wifi

  2. Wendi Martin | | Reply

    I have a windows 8x it’s a TMobile phone I use with Net10. I set up the MMS and APN after finding info on the internet. I spent two hours on the phone with Net10 and got nowhere. So I’m not wasting my time with that again. I had no issues until a couple days ago. Now I can get on the internet and receive MMS messages without issue but am unable to send any. Can someone help? PLEASE???

    • CamShy | | Reply

      Took a while but think I figured out your problem, which sounds like mine. At the bottom of the MMS APN page, change the IP Type menu to IPv4, it defaults to IPv4v6, just change that and it will download images on MMS. As for internet access, didn’t have to change anything and it works.

      • rick | | Reply

        Thank you I tried everything but your info got it to work, THANK YOU

    • eric | | Reply

      Check your date and time settings. When I’m having troubles like that, I find that my date or time are off. Just a suggestion.

  3. Heather | | Reply

    Hi Mark,
    I have a Nokia Lumia 920 and followed your guide completely. I am able to access the internet and I can receive picture messages but cannot send. Do I have to put in a max size for this to work? I’m lost at this point. Also wanted to say that on my phone I had to go to “cellular and sim” then click “sim” to access my apn settings. Just a little different than the screenshots you provide. Thank you for your help.
    Regards,
    Heather

    • Bob Thompson | | Reply

      Hi Heather,
      It’s Bob, not Mark 🙂
      The screens are different because you probably are using Windows 8.1 and I haven’t updated the guide.
      What settings are you using? Can you take screenshots and send them to me? Press Volume Up and Power Button at the same time
      You’ll have to email them to bob at the name of this website.

  4. mandy Crowe | | Reply

    Set the apn net10 byop Lumia 521 tmobile an it worked for about 3hours an then it just suddenly quit need help getting it back

    • Bob Thompson | | Reply

      Hi Mandy,
      what is your APN? When it stopped working does the phone show you have a network connection?

  5. Tom | | Reply

    My wife has a nokia lumina 920 we went with net 10. I just went through your tutorial on setting up pictures in texts my wifes phone wont recieve or send photos. I was in step 5 and entered all the apn adresses like tfdata, and then went back turned off wifi and still cant get an Internet connect? I tried all 3 and no luck? Any suggestions

    • Bob Thompson | | Reply

      Hi Tom,
      Did you use the link the article to look up what your APN is? I assume that you are using the Net10 ATT SIM and that your APN will be tfdata. Tell me, did you use ATT before, and do you know if ATT works well where you live?

  6. Chantal | | Reply

    Thanks again Bob, worked perfectly. Your site helped me with my Iphone about a year ago.
    I googled Net10 mms settings, their site said BYOP clicked that, then at&t and it gave me the settings, followed your guide where to enter them and it worked didn’t even have to reboot.
    Thanks again Chantal

  7. Maria Burns | | Reply

    Your instructions showed me exactly how 2 fix my phone finally!!!! Thank you so much!!! 🙂

    • Bob Thompson | | Reply

      Hi Maria,
      That is great to hear. Are you using a Lumia 920 or a different Windows phone?

      If you use social media, please follow us on Facebook, Twitter, Google+, and YouTube. In addition to keeping up with latest updates at smartphonematters you would be helping us launch social media efforts. click here
      Regards
      Bob

  8. Chris Duffey | | Reply

    Thank you for posting. I have a Nokia 520 and it worked like a charm

    • Bob Thompson | | Reply

      Hi Chris,
      That is great to hear. I think the Nokia 520 is an amazing phone, especially since it sells for under $100.
      Thanks for taking the time to comment. If you use social media, please follow us on Facebook, Twitter, Google+, and YouTube. In addition to keeping up with latest updates at smartphonematters you would be helping us launch social media efforts. click here
      Regards
      Bob

  9. jesse | | Reply

    i have a nokia lumina 520 with net ten and it wont let me send mms or get mms or group messageing i changed the mms settings to what the fourms say internet works fine. what can i do ?

    • Bob Thompson | | Reply

      Hi Jesse,
      Did you use the link in my guide to look up your APN settings on the net10 web site?
      Regards
      Bob

  10. Ashley lea | | Reply

    This helped me a lot. Awesome and easy steps. Thank you soon much

    • Bob Thompson | | Reply

      Hi Ashley,
      That is great news. Thanks for taking the time to comment. If you use social media, please follow us on Facebook, Twitter, Google+, and YouTube. In addition to keeping up with latest updates at smartphonematters you would be helping us launch social media efforts. click here
      Regards
      Bob

  11. zensea | | Reply

    I am completely new to smartphone.
    I am current Net10 user and have one sim card that uses ATT network (verified by starting network connection and sending emails to my XXXXXXXXXX(phone number)@txt.att.net).
    I purchased a Nokia 520 go phone from RadioShack today.
    I cut my sim card from my Net10 phone to fit into 520.
    Powered on 520. It did not say invalid sim card or anything else, but showed on right up corner “No service”.
    I can access internet via my WiFi and check my Gmail, but can NOT use phone to dial (no signal bars, no network).
    What should I do to get phone function working, then MMS.
    Please help me with detailed instructions or links.
    Thank you very much

    • Bob Thompson | | Reply

      Hi Zensea,
      I am not sure what the issue is. It could be that there is a difference in the SIM from your Net10 phone and one of their SIMs from the BYOP plan. How much are you paying a month for your net10 phone? When you bought the Net10 phone did you need to put the SIM in it? what color was the plastic card your SIM came on?

      If you have a friend with an att smartphone, you can try your SIM in their phone to see if it works and then you’ll know if the SIM has a problem.

      Please let me know.
      Regards
      Bob

      • Bob Thompson | | Reply

        You may also want to try going into the settings and doing a factory reset on the phone. Make sure to back up any data you have.

        Regards
        Bob

  12. Abby:) | | Reply

    Thank you LOADS the lady I called earlier today helped me accomplish nothing in an hour, and you managed to help in 10 minutes or so 🙂

    • Bob Thompson | | Reply

      Hi Abby,
      That is great news. Are you using the Lumia 920 or a different Windows phone?

      If you use social media, please follow us on Facebook, Twitter, Google+, and YouTube. In addition to keeping up with latest updates at smartphonematters you would be helping us launch social media efforts. click here
      Regards
      Bob

  13. Tom | | Reply

    Do I need to go through the unlocking process with AT&T. To be able to use this device on NET10?

    • Bob Thompson | | Reply

      Hi Tom,
      No. Not if you use the Net10 SIM. If you finished your contract or paid the Early Termination Fee, I would request the unlock. Its free. If you ever decide to give the phone to someone or sell it they will have more options and the phone is worth a little more money.

      Regards
      Bob

  14. Cindy | | Reply

    I do not see a link to your guide. It says to click “next page” but I don’t see it.
    Thank you.
    I sure hope this works. 🙂

    • Bob Thompson | | Reply

      Hi Cindy,
      You need to go to Page 2. I changed the Next Page > to page numbers because people didn’t see the Next Page. Go figure.
      Regards
      Bob

  15. DeWayne | | Reply

    Hello,
    I have a Nokia Lumia 800 and only have one screen for the cellular settings. I have the correct info for that but still cannot get the mms pic messages to work. Is there a way for it to work on this version of the windows phone or is it too old?

  16. gabby | | Reply

    I also have a Lumia 920 and did all these settings and i recieve mms pics but cant send any pics to anywhere.

    • Bob Thompson | | Reply

      Hi Gabby,
      Which settings did you try? Did you keep a list?
      Regards
      Bob

  17. Top Sh | | Reply

    I meant “they don’t support” mms on BYOPs..

  18. Top Sh | | Reply

    I also have a Lumia 920 – I decided to call them and Net10 told me that the reason it doesn’t work is that they support mms on “Bring Your Own Phone” (BYOP). and that maybe it will be supported at a later date… What a bunch of crock! They lure you to their “unlimited” that includes picture messaging but not all features work.

    • Bob Thompson | | Reply

      Hi
      Did you follow my guide? I agree they should be clearer about MMS. I think they say unlimited talk, text, and data and leave out the mms part.
      Let me know we can probably get it to work.

      Regards
      Bob

  19. Brandi | | Reply

    Hello, I have tried all 3 of the apns and none seem to work for me. I’m not sure how to fix this or what I am to do. Any further help?

    • Bob Thompson | | Reply

      Brandi,
      I can try to help you. What phone are you using? Do you know the model number? Do you know if you have the Net10 ATT or TMobile SIM card? (One is Blue the other is Pink)

      Regards
      Bob

  20. Angela | | Reply

    Hi Bob,

    I am using the att.mvno and worked with one mms to myself and to another phone. Then asked a friend to send one after sending this comment and so far nothing. He resent and still nothing. When I called straight talk twice they had me set up with (forgot the apn name), 66.209.11.33, 80, http://mmsc.cingular.com. I used to be able to send mms but not receive but now can’t do either. Funny part is my internet seems to work with any apn setting. Access point is an app that I think appeared on phone thru Nokia when doing updates? It basically has APN setups for internet/apn. There you can add an APN and make which ever one active and the others are inactive.

    • Bob Thompson | | Reply

      Hi Angela,
      Can you make all the apns inactive in this app? If so, then follow my step by step guide. Make sure wifi is off. Verify you internet works with the att.mvno APN. If not try tfdata. If att.mvno works, then set the mms APN info and test.

      This APN app might be fine, I’m just not familiar with it and you want to try to eliminate it from causing a conflict.
      Regards
      Bob

      • Angela | | Reply

        No at least one of the apn’s have to be active and that is my problem. Also the problem is that I don’t think you can delete/uninstall the app.

        • Bob Thompson | | Reply

          I don’t even remember that app being on my phone, but I just got it a few weeks ago so I may have not noticed it. I don’t want to tell you to delete that app, maybe just see if you can follow the guide.

    • Bob Thompson | | Reply

      Hi Angela,
      Did you ever get this fixed? I got my Lumia back and I didnt have that app you were talking about.
      Regards
      Bob

  21. Angela | | Reply

    Hi Bob,

    I have the ATT Lumia 920 and was working fine until a few weeks ago and now mms is not working. It is also weird b/c if I set these settings it will work for a little while then stop working, so I have no idea what is going on. I noticed we have cellular settings and the access point also. It seems that access point has to have one access point. Do we configure this part instead of the cellular? Also maybe need to buy a new SIM b/c its too old? I really like this phone until now. Please tell me there is hope!

    • Bob Thompson | | Reply

      Hi Angela,
      I am not sure what the issue is. There has been a bunch of changes going on with Net10 and Straight Talk. They have used three different APN values and several sets on MMS values for the last few years. A lot of customers were using the att.mvno and wap.tracfone settings and find out they were moved to tfdata, mms3.tracfone.com and http://mms-tf.net. Are those the settings you are using? I am not sure that this is an issue with your phone. Several iPhone users are reportedly able to send but not receive MMS.

      I lent my Lumia to a friend to try out, so I don’t have it here to look at the settings. I am not sure what you mean by “cellular settings and the access point also”. Can you point out what you mean in the screenshots in my guide? in Cellular there is an internet APN and an MMS APN, you need to configure both.

      I am not sure that your SIM is the issue, but if it is older than Sept / October I’d order a new one from the web site. You’ll get 4G LTE with a newer SIM, if the ATT network has LTE where you live. It’s much faster.

      Let me know what settings you are using…
      Can you tell me how long your MMS works for after you reenter your access point?
      Keep an eye on the smartphonematters.com home page for any info I come up with. You can leave another comment to follow up if you don’t hear anything from me.

      Regards
      Bob

      • Robyn | | Reply

        Hi Bob,

        I have a AT&T Nokia Lumia 920 with a new 4G LTE Sims card and have tried all the MMS settings listed in your guide and still no luck. Any suggestions.

        Thanks in advance

        • Bob Thompson | | Reply

          Hi Robyn,
          OK. Where did you get your Net10 SIM? Are you using Net10’s ATT compatible SIM or Net10’s T-Mobile Compatible SIM?
          Look up your APN settings http://www.net10.com/byop_apn/index.jsp choose Android 4.0 & 4.1 as your phone type. Let me know what NEt10 says your APN settings are?
          Regards
          Bob

  22. Mark n | | Reply

    Thank you SOO much for this guide. Used it with a straight talk huawei h883g windows 8 phone using a BYOP sim(it came with its own sim as well) we just swapped in the BYOP sim, but It initially wouldn’t do data or receive picture texts. Calls and regular texts worked fine. After a call to ST support got me not much other than data working, I started digging and found this guide and matched the mms settings to data using the info you provided in the add mms apn section. Alls right right in the world now, and the phone works the way it’s supposed to. Thanks again. You’ve saved my sanity.

    • Bob Thompson | | Reply

      Hi Mark,
      That is great news. I am happy the guide helped. I just published the guide on Saturday night! So I am super thrilled that someone found it, used it, and even left me a comment!
      Do you mind, can I ask how you found my guide? My iPhone guide and some of my android guides show up in prominently in google. This guide is too new. I am just curious.
      Regards
      Bob

Leave a Reply

Your email address will not be published. Required fields are marked *